Wednesday, June 22, 2011

RS1.EXE works with SSRS 2008 R2 with SP1

Thanks to my anonymous friend, Baptiste Lefran├žois, it appears that my RS1.exe build still works with SQL Server Reporting Services 2008 R2, but you need Service Pack 1. Here's my original post:


And here's the description, in my gracious friend's own words:

"Hello Joe,

Thanks for your help, I've understood my mistake but finally my problem was an official bug of SQL Server Report Service. I just want to tell you how I resolved it for next person who will be in the same situation. My problem was the LogonUser didn't return any cookie, and my authCookie was always null, never affected :( The specific error message was : "Authorization ticket not received by LogonUser". But I've already followed all recommended procedures on the msdn but never resolve my problem. My authentication form on ReportServer page worked perfectly with any web navigator, but with a console application impossible, allways the same [... :)] error =/ I've tried to authenticate thanks of navigator on ReportsManager page and... surprise I got the same error : "Authorization ticket not received by LogonUser". After lot's of search and googling , I've read an article explaining this bug. It was in fact an official bug and Microsoft published a fix whish was after included in the SQL SERVER 2008R2 SP1. I had only the SQL SERVER 2008R2 with no update. After install the SP1, I tested your "old" RS Utility for form authentication, rs1.exe. And It works perfectly now. Thank's so much ! Maybe my bug and the solution I've found will be helpfull for the future ;)

Thanks a lot, So Nice! =)

Baptiste"

2 comments:

  1. I have no words for this great post such a awe-some information i got gathered. Thanks to Author.

    ReplyDelete
  2. Thanks for the great work. Is Rs1 going to support Mgmt2010 endpoint soon?

    Thanks again

    ReplyDelete